Updating PHP5-APCu on Ubuntu 14.04 LTS for ownCloud compatibility

If you run your own ownCloud (not the Enterprise version) on Ubuntu 14.04 LTS, you will most likely have noticed that it works but complains on the admin page about APCu being lower than version 4.0.6, which is the version ownCloud 8 and higher needs. Now there is an easy fix to updating PHP5-APCu on Ubuntu 14.04 LTS for ownCloud compatibility.

The top of the ownCloud admin page, showing the warning
The top of the ownCloud admin page, showing the warning

OwnCloud will run without fixing this, so there’s no immediate need to resolve this issue, but it does work considerably faster with a working memory cache. I highly recommend configuring a working cache.

APCu comes with PHP5 and is recommended by the ownCloud developers. It is also widely available on the various Linux distributions out there. It’s also easy to configure ownCloud to use PHP5-APCu.

Until recently, users of Ubuntu 14.04 LTS were stuck with PHP5-APCu 4.0.2. which resulted in the error shown. However, the guys at Canonical have gotten their act together and a newer version is available in the backports repository, which means you can install the latest and greatest PHP5-APCu with a single command.

sudo apt-get install php5-apcu/trusty-backports

This command pulls in and installs PHP5-APCu version 4.0.7. at the time of writing, which satisfies ownCloud’s needs nicely. Restart your webserver after the installation.

Next, head over to your ownCloud config.php file and the following line:

'memcache.local' => '\OC\Memcache\APCu',

as per the instructions found in the ownCloud Server Administration Manual. Don’t forget to restart your webserver a second time after making this modification.

Enjoy a faster and more responsive personal cloud experience!

Any thoughts about this? Please leave a comment!